Indev Joomla! extensionsNow that the Joomla! project has ended support for Joomla! 1.5 with its end-of-life in April 2012 (update: extended to September 2012), it's also time for us at Chill Creations to communicate our Joomla! version support policy. I acknowledge the special position of Joomla! 1.5, and that is why we have decided to fully support Joomla! 1.5 even longer than the Joomla! project, with bug and security fixes.  

 

Joomla! 1.5 end-of-life

Policy updated December 2012

We will phase out support for Joomla! 1.5 in our Joomla! extensions starting September 2012. 

  • Starting September 2012 we will stop promoting the support of Joomla! 1.5 in our extensions.
  • The versions that support Joomla! 1.5 will be clearly marked and stay available for download in our downloads section.
  • We will release new versions that are compatible with Joomla! 2.5 and 3.x as soon as possible.
  • These new versions will no longer support Joomla! 1.5.
  • These new versions will mark the end off technical support and bug fixes for Joomla! 1.5 for that extension. 
  • If major security issues are found in any of the Joomla! 1.5 versions in 2013, we will provide a security fix if at all possible. 

All customers that have an active order will continue to receive support and bug fixes and have access to downloads for the Joomla! 2.5 compatible versions of our extensions for the entire lifetime of Joomla! 2.5. If your order is active when we release the Joomla! 3.x versions, you will also get access to those new versions. 

Read more: Joomla! 3.0 and the status of our Joomla! 3.0 extensions

A major security issue has been found in Joomla! 1.5, update your old site with this Joomla! 1.5 security patch
If you have a question about this announcement, ask us now.

cciDEAL Virtuemart

If you do not use cciDEAL Virtuemart, skip this section and read on at "Advice and resources".

Informatie over cciDEAL Virtuemart in het Nederlands Lees dit bericht in het Nederlands op Joomla! Virtuemart iDEAL.nl!

 

There is one exception to the above policy. cciDEAL Virtuemart will not be updated to support Joomla! 2.5, as its functionality has been replaced by cciDEAL Platform. Therefore, cciDEAL Virtuemart will have a slightly different support period, depending on when you purchased it.

  • If you purchased cciDEAL Virtuemart before June 2010, you bought the extension under the following conditions: installation on one website and unlimited support for the extension lifetime. You have now had support and access to updates for 2 to 4 years. On September 30th 2012, the product lifetime of cciDEAL Virtuemart ends and so will your access to support and updates.
  • If you bought cciDEAL Virtuemart after June 2010 and have an active order you will receive support for cciDEAL Virtuemart as long as your order is active. For example, if you bought cciDEAL Virtuemart in May 2012, we will support you until May 2013.
For customers in the last group, support will be limited in 2013 as we will not fix new major issues in cciDEAL Virtuemart caused by, for example, new PHP or browser versions released after January 2013. The thinking behind these limitations, is that our support of cciDEAL Virtuemart in 2013 is an extra service for customers that for some reason aren't ready to migrate to Joomla! 2.5 yet. But these customers should realize that they are already using outdated and unsupported software (Joomla! 1.5 and Virtuemart 1.1).
 
iDEAL 3/SEPA: for customers that have purchased cciDEAL Virtuemart in the past, we have developed a final update with support for iDEAL 3/SEPA. After the announcement of iDEAL SEPA by the banks we have decided that this is the best solution for customers that can not migrate to Joomla! 2.5 before 2013. For more information, please contact us. We will also pro-actively contact all cciDEAL Virtuemart users via our newsletter. 

Advice and resources

Because of the end-of-life of Joomla! 1.5, our advice is to stop installing this version for new websites. A responsible website developer should actually have stopped installing 1.5 for new websites months ago. Joomla! 2.5 is the only version of Joomla! you should be using at the moment. We also advice starting preparations for the migration to Joomla! 2.5, if you have not already.

Migration to Joomla! 2.5 is not impossible. It is off course a slightly complex job that takes some preparing and experimentation, but from experience I can inform you that the sooner you start, the easier it gets.

Below I have collected a few resources which you should make yourself familiar with. They explain, for example, the new Joomla! development strategy and versions, and migration to Joomla! 2.5. 

Joomla! CMS Development Strategy

Should I upgrade my website to Joomla! 2.5

Joomla! versions and updates explained

Joomla! Development Status

Upgrading and migrating Joomla!

Convert a Joomla! template to Joomla! 2.5