ccInvoices - invoicing and billing for Jooma!

We have just released ccInvoices 1.4.1, which adds compatibility for Joomla! 1.6/1.7 to our user friendly joomla invoicing/billing extension. This is a release candidate, which means there are no known bugs, but we advice caution (and a Joomla! backup) when upgrading.

Although we have extensively tested this new version, it is entirely possible that there are still remaining bugs. As always, we are available to timely solve any issues you might encounter. For every issue, please submit a support email.

Below is a screenshot of the invoices overview in Joomla! 1.7. Off course, ccInvoices 1.4 should also have no issues when used in Joomla! 1.6, but as Joomla! 1.6 is now EOL (end of life = no longer supported), and Joomla! 1.7 is an easy (security) upgrade, we advice everyone to upgrade and use Joomla! 1.7.

The latest version of ccInvoices can be downloaded from the ccInvoices downloads section.

Invoicing system for Joomla! 1.6 1.7 2.5