Frequently asked questions
[mwm-aal-display]
How to show modules after a payment?
cciDEAL will automatically register what modules are shown on the last page before the customer goes to payment. When he returns, those same modules will be shown in the return message. So actually, you have to do nothing to show these modules.
[Virtuemart] No redirect to payment after checkout
Problem: after placing an order in Virtuemart, Virtuemart does not redirect to cciDEAL or the payment provider.
This problem can have multiple causes and solutions:
- If you have custom templates for the checkout, try disabling them. Does Virtuemart then redirect? In that case there is an issue in your templates (maybe they are outdated) that you need to research and solve.
- If you are using a One Page Checkout (OPC) extension with Virtuemart, please remember to always use the latest version of that OPC extension, with the latest version of Virtuemart and cciDEAL. You might otherwise get issues with payments if you only update Virtuemart or cciDEAL and not the OPC extension.
- Use the Developer Tools in your browser (also known as inspector) to check for any JavaScript errors that might be shown. In the past even a badly written FaceBook extension caused a conflict with Virtuemart/cciDEAL, so this is an important thing to research. Disable such and extension and test again to be sure if it’s the cause of the issue.
- Consult changelog for technical requirements & latest versions updates for cciDEAL Integrations – For Virtuemart 4x is VM4 payment Changelog & Adding iDEAL and Other payment methods to Virtuemart
iDEAL error: required fields missing
Not all configuration details are entered correctly. Go to Components > cciDEAL Platform and check if all details are present, then save the configuration. If you then still have the issue, please create a new ticket.
Payment status not updated or is always “not paid, please retry”
- Localhost: You can not use/test iDEAL or cciDEAL Platform on your localhost, you need to test it on a real server. So move the current website to a live server (a test directory is possible) and test it there.
- HTTP to HTTPS redirect: does your site run on HTTPS? Make sure users can only access the site on HTTPS. Otherwise payment providers might get webhook communication issues when the HTTP communication is redirected to HTTPS, which causes the POST information to be removed from the webhook communication. Also make sure System > Global configuration > Server > Force SSL is set to “Entire site”. And possibly add a hard-coded redirect from HTTP to HTTPS to your .htaccess file (Search for details on how to do this).
- Offline mode: during iDEAL/payments testing the website should not be in “Offline mode” (Site > Global Configuration > Site Offline), as this will block the iDEAL communication.
- Firewall or htaccess authorization: during iDEAL/payments testing the website should not be hidden behind any kind of “full site firewall” or htaccess authorization. It’s fine to only secure the /administrator folder with htaccess, but putting the entire site behind htaccess will block the iDEAL communication back to the site.
- Security extensions (RSFirewall, sh404SEF, Akeeba Admin Tools) and a more restricting .htaccess file than default Joomla! will in some cases also block the iDEAL communication. Turning them off is not always the solution (sh404SEF), you need to uninstall them to make sure they are not the cause of this issue.
- RSFireWall: in the case of RSFirewall, disable “System – RSFirewall! Active Scanner” plugin. If you want to keep using the RSFirewall Active Scanner, go to Firewall Configuration > Active Scanner > Deny access to the following User Agents, disable “Java” and make sure country blocking is disabled!
- Akeeba AdminTools:
- Go to AdminTools > .htaccess Maker > Block access from specific user agents and set that to “no”.
- In “Allow direct access to these files” add components/com_ccidealplatform/models/ccideal.php and components/com_ccidealplatform/controller.php.
- Go to “Allow direct access, including .php files in these directories”, and add “components/com_ccidealplatform/”.
- Disable the CSRF shield.
- Webhosting companies: Your webhosting company might also block communication by Mollie. Explain the issue to your webhoster and tell them to check their access logs or Firewall logs for bot requests to a URL containing /index.php?option=com_ccidealplatform. This communication (by the payment provider) should not be blocked.
- Gzip compression: Is Gzip compression enabled in the Joomla global configuration? Try disabling and try again.
- Communication test: It’s possible that external communication to cciDEAL is blocked (by a firewall, security extension). In your terminal type curl yourdomain.com/index.php?option=com_ccidealplatform and make sure that you don’t get any messages like “Blocked, likely Malware” or things like that. The response should be a Joomla template, any almost all responses are okay (302 Found, document moved), just not messages with an error or block.
- With older Joomla versions, there appears to be a conflict when the plugin “Language filter” (Taal filter) is enabled. If ypu are still on those is time to migrate to more recent versions. Please check in System > Plugins if you have this enabled. If you do, disable it, and test making a payment again.
What if Klarna – Klarna (Later, Now, In 3 Parts) to Virtuemart payment method order is not appearing in the Mollie dashboard & cancelled order is not to be send as confirmed?
Thank you for your Order!” is the default message for pending or successful orders.
If the payment status is “Failed”(not “Cancelled”), You get an order message “Your payment was cancelled. Please contact us.
” You can choose order status depending on payment status.
Note : You need to enable just Klarna in your Mollie dashboard.
When consumer selects this option, they will be redirected to the Klarna gateway, where it will be decided what Klarna payment methods (Later, Now , In 3 parts ) the consumer is entitled to based on several factors such as credit score, location, currency, etc.“ All on Klarna’s side.
FAQ: You get this error
Error executing API call (422: Unprocessable Entity): The payment method is not enabled in your website profile. Field: payment.method. Means The payment method used is not enabled in Mollie.)
Note : Consult changelog for technical requirements & latest versions updates for cciDEAL Integrations – For Virtuemart 4x is VM4 payment Changelog & Adding Klarna – Klarna (Later, Now, In 3 Parts) to Virtuemart
How to disable Bootstrap or jQuery in cciDEAL
ccNewsletter 2.x and up: In ccNewsletter 2.x+ we implemented “Chill Creations Bootstrap” to load Bootstrap and jQuery in sites that do not load them already. You can disable “Chill Creations Bootstrap” in the configuration of our extensions. Older versions: Assuming that your template folder is called mytemplate, copy: media/akeeba_strapper/strapper.ini to templates/mytemplate/media/akeeba_strapper/strapper.ini Then read the contents of strapper.ini to learn how to disable Bootstrap and/or jQuery. These settings will automatically apply to all extensions that use Akeeba Strapper, such as ccNewsletter, ccInvoices, CookieConfirm and all extensions from Akeeba.
[MOLLIE] Not redirected to iDEAL after selecting bank
Question: After selecting iDEAL, I select a bank in the dropdown, but after that I am not redirected to the bank iDEAL page, sometimes I am redirected back to the site home page instead.
Please check all these options:
- Make sure mollie.com account is active for receiving iDEAL payments, as described in the manual.
- If you have set Mollie to test in cciDEAL Platform, make sure its also set to test on mollie.com under “Mijn betaaldiensten > Instellingen > iDEAL API testmode > iDEAL API testmode aan”. Or if its set to production, make sure testmode is disabled.
- Make sure the payment amount total is more then €2.
- In cciDEAL Platform find the Mollie ID, then go to mollie.com and under “Mijn account > Account gegevens > Partner ID / klant ID” make sure the ID’s are 100% the same.
- Ask the hoster if they have “fsockopen” enabled and not firewalled. This is needed for the XML communication of mollie.com.
FAQ’s : Error notifications and what to do:
- Error notification : When saving entries error message received: Fatal error: Declaration of ccNewsletterControlleracknowledgement::save() must be compatible with Joomla\CMS\MVC\Controller\FormController::save($key = null, $urlVar = null)
Solution: Please update to ccNewsletter latest versions as of 3.0.5 + , PHP 8, Joomla! 4 +.
The save() function must have the same arguments as in the parent class. Joomla! 4 updated the parent class arguments.
- Error notification: Deprecated : Function strftime() is deprecated in /home1 /Liverpool/public_html/libraries/scr/HTML/HTMLHelper.php on line 1076
This error appears because the version of Joomla is 4.2.8, for php 8.1 it should be at least 4.2.9
Joomla 4.2.8 also has a deprecated strftime() function in the Joomla core file (/libraries/scr/HTML/HTMLHelper.php on line 1076), so you need to update Joomla! to fix it . Errors appears because the version Joomla! 4.2.8, for PHP 8.1 it should be at least 4.2.9.
- Error notification :1366 Incorrect integer value -> Return to dashboard
Solution : Please update your extension accordingly.
- Error notification :Attempt to assign property :Return to dashboard
Solution : Please update your ccExtension accordingly.
- Error notification: : Error appears when connecting to Mollie : 500 Internal Server error message appears when in cciDEAL the button test payment is pressed

Solution: Error means there is something wrong on your server.
Check the logs to find the error. Check your IP server number, then check your SMTP settings and adjust if you need to and if your sever changed IP number. If settings need to be corrected, do so for correct PHP. In brief: An IP # check & using correct SMTP settings for sending to correct PHP = error gone
- Error Notification: Status from Draft to Open remains Draft , invoice status or # does not change & invoice details are not saved successfully.
Solution : In the configuration “Invoice # start” it should be a number only, as it is [invoicenumber]. Anything else causes an error
Wrong : “ID-[invoicenumber]-[mm][dd][yy”
Right : “123-[invoicenumber]-[mm][dd][yy”
Also: When changing the status from DRAFT to OPEN, a new ID is created that must be greater than the value of the “Invoice # start” field (and of course greater than the previous invoice ID).
The system will compare the new ID with the value input in the “Invoice # start” field. To avoid errors:
- Change the value to 0
- Make sure the configuration is number only
- Do not use special characters

- Error: Attempt to assign property ” item_price_excl_tax on array “
Tax % : Re: ” item_price_excl_tax ” -> ” item _ tax _percentage : 0 ; “When adding a new item, and the field in the configuration is empty error can appear.
Solution: When adding a new items, do check the “Possible tax values” if empty, if so do fill it in. Also let ccInvoices do what ccinvoices is intended to do that is -> ‘The tax of the invoice will be shown in the total (ccInvoices will calculate this). If by any chance you want to, for any customized reasons, leave the field “Possible tax values” empty it will be ok if you have the extensions latest version.
- Error Not possible to install the newest version and warning appears ?
Warning is : Metaregistrar: JScript Scripts are dangerous in email (88getPaymentStatus.js)
> Please logon to [filter.yourdomainprovider.net](http://filter.yourdomainprovider.net/ “”) to review the message with message id: 1pwIn2-000C55-Kh.
\–
Postmaster
Metaregistrar
[filter.yourdomainprovider.net](http://filter.yourdomainprovider.net/ “”)
Solution:
Above Warning appears when sending the ccExtension as an attachment.
Check your workflow and prior modifications.
When updating to major versions you need to do a little investigation. Major releases almost always have large new features or changes which might impact your workflow or current installation and custom modifications . We advise reading the extensions changelog to see if these changes impact you in any way and do a little investigation first hand . Also : We always advise creating a backup with Akeeba Backup. For any questions you might encounter when creating your backup see: www.akeeba.com/contact-us. Please note that when updating or upgrading all custom modifications you might have done will be lost.
FAQ’s When downloading, updating and installing components and receiving error notifications.
When experiencing issues and receiving error notifications in the following scenarios:
- Moving the site to a new hosting account, new server and not being able to get the extension .
- Updating seems to fail. Where/how to update?
- Help, I cannot download
- Is you Download ID correct ? And where to find it?
- Help, I cannot get component installed
- Moving old to new
FAQ: Is my download key correct? Do I have an active account? Where can I find my download key?
You can find the Download ID here (and please do also check that your subscription is active):
https://www.chillcreations.com/checkout/my-account/
Please make sure you have that Download ID set in the configuration for the extension. Your Download ID is NOT your subscription ID, order ID or Invoice ID!
If that doesn’t work, please follow this troubleshooting doc, it just takes a few minutes.
https://www.chillcreations.com/checkout/troubleshooting-extension-update-issues/
FAQ: Moving old to new
On the new site (the one that’s moved) we would delete the old ccExtension , and then download the latest ccExtension version from https://www.chillcreations.com/checkout/my-account/
After downloading it, install it in the new site. Check the API keys and if needed, add them.
After that, test .
FAQ : Where to find it all
The current version can be found in your site
Go to your site -> Component > extension
Scroll down to the footer and find the version in the gray area. If you see “ccExtension version & number” or higher there, you are using the latest version.
You should already have seen this update in Joomla Extension Manager (Site > Extensions > Manage > Update) if you have recently updated extensions on your site.
FAQ : If you don’t have this version and don’t see the update in the Extension Manager.
There may be something wrong with the updater on your site.
FAQ: Where to find the download key?
Your download ID is to be found in your account chillcreations.com > My Account.
FAQ : Where to get the downloads from ?
If you have a new subscription, purchased , get the downloads from:
https://www.chillcreations.com/checkout/my-account/downloads/
If you have an active subscription get the downloads from the old downloads system:
https://www.chillcreations.com/prices/
View the changeling for all extensions here:
https://www.chillcreations.com/checkout/changelogs/ccnewsletter/
https://www.chillcreations.com/checkout/changelogs/ccideal/https://www.chillcreations.com/checkout/changelogs/ccinvoices/
FAQ : When experiencing errors when installing components.

When you are experiencing issues installing an ccExtension component but no issues downloading the component ( in this case as an example ccInvoices ) the advise is to
- Joomla! 4, PHP 8 and MYSQL 8
- Check if it is a fresh install of Joomla! 4, if not, it is advisable to install a fresh version of Joomla! 4.
- Adress any other errors (other components ) which are present on the site.
- See if it is an upgraded version form Joomla! 3 and other components have a “Class ‘JRequest’ not found” error
- Check if JRequest was completely removed form Joomla! 4
- If old site is moved to a new server
During testing cases, when installing a fresh version of Joomla! 4 in test environments, we do not experience any errors when installing our components .Our advice is address issues found and install a fresh version . ( Always make sure you created an Akeeba backup!)
If still experiencing an issue and subscription is active, mail us https://www.chillcreations.com/contact/
FAQ’s : When moving form old to new server and receiving error notifications
Receiving error notification can mean that there is something wrong on your server .
Check the logs to find the error.
Check your IP server number, then check your SMTP settings and adjust if you need to and if your sever changed IP number. If settings needs to be corrected, do so for correct PHP. In brief: An IP # check & using correct SMTP settings for sending to correct PHP = error gone
FAQ: ccExtension module suddenly disappeared when installing & transferring content to Joomla! 4?
Check your trash bin, when editing and changing stuff you might have removed it. Find and reactivate .
FAQ: CORS error – (: CORS-aanvraag is niet gelukt)
A common cause of a CORS error is an `http` to `https` request or vice versa. It is not related to ccExtensions. It is more like a server/hosting issue.
Do consult with your hosting/server and explain where this error appears.
https://appmaster.io/nl/glossary/cross-origin-resource-sharing-cors-nl
FAQ : IN3 payment method add in combination with Mollie
Available since versions ccNewsletter 3.0.8, cciDEAL 6.0.11, ccInvoices 4.0.8, IN3 payment method in combination with Mollie.
Note : We advise to keep ccExtensions updated to latest versions.
IN3 lets customers make payments in 3 interest-free instalments over 60 days. With Mollie and in3, your customers can use their preferred payment method, iDEAL, to buy now and pay later. Currently in3 is only available to consumers residing in The Netherlands.
For any support concerning plugin IN3, do consult IN3 plugin support.
To allow customers to pay in 3 parts, with the Dutch payment method iDEAL with a settlement delay of 15 days after paying the first installment.
First term paid when they place their order, 30 days second installment after first payment, 60 days (no later than) final installment after the first payment , or pay remainder in full before installments.
Virtuemart cart selected payment or choose other payment, test profile test mode payment, Thank you page view your order IN3 pay in 3 parts.
Consult our Changelog page for technical requirements required
Consult manual for Adding iDEAL and Other payment methods to Virtuemart / Hikashop / ? RSForm Pro for our ccExtensions
Maybe handy
https://www.mollie.com/payments/in3
https://help.mollie.com/hc/en-us/articles/6074981751058-How-do-I-activate-in3-
